Différences de version de la bibliothèque MySQL ?

Hello,

Si vous rencontrez ce message d’erreur dans PhpMyAdmin, notamment suite à une mise à jour de LAMP, voilà ce qu’il signifie exactement.

Message d’erreur:

La version de votre bibliothèque MySQL (5.0.77) diffère de la version de votre serveur MySQL (5.1.54). Ceci peut occasionner un comportement imprévisible.

En fait, la version du client, à savoir PHP est configurée pour fonctionner avec la version 5.0.77 de MySQL. Or, en mettant à jour MySQL sur le serveur, celle-ci est montée pour devenir 5.1.54 d’où l’incohérence !

Pour cela, il faut recompiler PHP et Apache !

Petite astuce pour trouver une chaine de caractères dans un fichier.

find . -name "*" -exec grep -Hn "5.1.54" {} \;

Enjoy !

Laisser un commentaire